Past incidents Return to status page

Outlook Connected Email is unavailable for some customers

Incident Report for HubSpot

Resolved

Between 8:40 PM UTC and 9:45 PM UTC on March 1, Microsoft reported a global outage with Microsoft 365 services.

This outage resulted in Outlook connected email to be unavailable in HubSpot.

Some HubSpot users may have also received an email notification that their Outlook inboxes have been disconnected from their HubSpot accounts.

As of March 2 at 1:22 AM EST, all Outlook inboxes were reconnected to HubSpot accounts.

We apologize for any confusion and appreciate your patience as we reconnected inboxes.
Posted Mar 02, 2025 - 01:22 EST

Update

We continue to work on reconnecting all affected inboxes. We will be back with an update within 3 hours.
Posted Mar 01, 2025 - 23:17 EST

Update

We are working on reconnecting all affected inboxes.

In the interim, users with disconnected inboxes can manually reconnect them if they prefer not to wait. We will be back with an update within an hour.
Posted Mar 01, 2025 - 22:20 EST

Update

We have identified the issue that caused Outlook Connected Email to be unavailable since 3:00 PM EST (UTC -05:00) on Mar 1, 2025.

We are working to reconnect all affected inboxes.
We will be back with an update within an hour.
Posted Mar 01, 2025 - 21:23 EST

Identified

We've identified the issue that's caused Outlook Connected Email to be unavailable since 3:00 PM EST (UTC -05:00) on Mar 1, 2025. We're addressing the cause of this issue and will update this page when we have more information. We will be back with an update within an hour.
Posted Mar 01, 2025 - 20:12 EST
This incident affected: Integrations.