Past incidents Return to status page
Marketing Email Send is currently delayed for some customers
Incident Report for HubSpot
Resolved
Marketing Email Sends is no longer experiencing delays. We've identified and addressed the cause of the delays on Sep 1, 2023. Any previously delayed email sends has now recovered.
Posted Sep 01, 2023 - 05:00 EDT
Identified
We've identified the cause of the Marketing Email Send delays of up on Aug 31, 2023. These delays may impact tools such as Marketing Email Sends in HubSpot. Our team is investigating the cause of this issue and will update this page when more information is available.
Posted Sep 01, 2023 - 04:28 EDT
This incident affected: Marketing Tools.