Past incidents Return to status page
HubSpot APIs are experiencing timeouts
Incident Report for HubSpot
Resolved
API requests are now returning as expected. We've identified and addressed the cause of the API slowness that began at 4:29 PM EDT (UTC -04:00). The issue is now fully resolved.
Posted Sep 25, 2024 - 23:30 EDT
Monitoring
We've addressed the issue that was causing API timeouts on public APIs. We're continuing to watch API response times.
Posted Sep 25, 2024 - 22:55 EDT
Identified
We have identified the root cause of the issue that is causing API timeouts. We are now actively working toward resolving it.
Posted Sep 25, 2024 - 18:48 EDT
Investigating
HubSpot public APIs are experiencing some unexpected timeouts. The team is investigating and trying to determine the root cause to resolve the issue.
Posted Sep 25, 2024 - 17:56 EDT
This incident affected: HubSpot APIs.