Past incidents Return to status page
Viewing form submission file uploads are currently unavailable for some customers
Incident Report for HubSpot
Resolved
The view of form submission file uploads in HubSpot is now fully operational. We’ve identified and addressed the issue that caused file uploads to be unavailable from 2:15 PM ET to 4:13 PM ET.
Posted Nov 21, 2019 - 17:07 EST
Monitoring
We’ve addressed the issue that’s caused the view of form submission file uploads to be unavailable. We’re monitoring performance to ensure the process recovers properly.
Posted Nov 21, 2019 - 16:35 EST
Identified
We’ve identified the issue that’s caused the view of form submission file uploads to be unavailable. We’re addressing the cause of this issue and will update this page when more information is available.
Posted Nov 21, 2019 - 16:17 EST
This incident affected: CRM.