Past incidents Return to status page
Reports and other tools using engagement activity data are lagging or failing to load
Incident Report for HubSpot
Resolved
Engagement data processing in HubSpot is now fully operational. We’ve identified and addressed the cause of the issue and the incident has now been fully resolved.
Posted Jun 03, 2020 - 17:38 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 03, 2020 - 17:14 EDT
Monitoring
We’ve addressed the issue causing engagement data delays. We’re monitoring performance to ensure the process recovers properly.
Posted Jun 03, 2020 - 16:28 EDT
Update
Tools in HubSpot that use engagements data are still experiencing some delays and intermittent loading issues. We’re continuing to investigate the cause of this issue and will update this page when more information is available.
Posted Jun 03, 2020 - 14:34 EDT
Identified
Engagements data is still experiencing delays and intermittent loading. We’re continuing to investigate the cause of this issue and will update this page when more information is available.
Posted Jun 03, 2020 - 12:36 EDT
Investigating
We are experiencing a delay in displaying updates to engagement activity data since 9.05am ET. Tools affected include reports, tasks, and conversations. No data has been lost. We are investigating the cause if this issue and will update this page when more information is available.
Posted Jun 03, 2020 - 11:12 EDT
This incident affected: CRM, Sales Tools, Service Tools, Reports, and Mobile.