Past incidents Return to status page

HubSpot is currently unavailable for some customers.

Incident Report for HubSpot

Resolved

HubSpot is now working for all users. We identified and addressed the root cause of the issue that prevented HubSpot from loading, and the issue is fully resolved. No data was lost.
Posted 5 months ago. Sep 25, 2024 - 15:42 EDT

Monitoring

We've addressed the issue that prevented HubSpot from loading beginning at 5:47 AM EDT (UTC -04:00) on Sep 25, 2024. We're monitoring performance closely to ensure the software recovers properly.
Posted 5 months ago. Sep 25, 2024 - 12:37 EDT

Identified

We've identified a return of the issue that prevented HubSpot software from loading at 5:47 AM EDT (UTC -04:00) on Sep 25, 2024. We're addressing the cause of this issue and will update this page when we have more information.
Posted 5 months ago. Sep 25, 2024 - 09:29 EDT

Monitoring

We've addressed the issue that prevented HubSpot from loading beginning at 5:47 AM EDT (UTC -04:00) on Sep 25, 2024. We're monitoring performance closely to ensure the software recovers properly.
Posted 5 months ago. Sep 25, 2024 - 06:19 EDT

Investigating

HubSpot is currently unavailable for some users. We're investigating the cause of this issue, and we'll update this page when we have more information.
Posted 5 months ago. Sep 25, 2024 - 05:54 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.