Past incidents Return to status page
HubSpot is slow to load for some customers
Incident Report for HubSpot
Resolved
Between 4:37 PM and 6:10 PM EST, some customers on the West Coast of the United States had loading or timeout issues in HubSpot due to an outage on our third-party cloud platform, Cloudflare. Cloudflare has resolved the root cause of the issue, and all tools in HubSpot should now load properly. You can follow the issue here: https://www.cloudflarestatus.com/incidents/d4g3q6bqzfnr.
Posted Feb 15, 2022 - 19:12 EST
Update
As of 6:10 PM EST, Cloudflare has reported that their systems are recovering. We’re monitoring the issue closely to ensure all HubSpot tools recover properly. You can follow the issue here: https://www.cloudflarestatus.com/incidents/d4g3q6bqzfnr.
Posted Feb 15, 2022 - 18:30 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2022 - 18:26 EST
Identified
As of 6:10 PM EST, Cloudflare has reported that their systems are recovering. We're monitoring the issue closely to ensure all HubSpot tools recover properly. You can follow the issue here: https://www.cloudflarestatus.com/incidents/d4g3q6bqzfnr.
Posted Feb 15, 2022 - 17:28 EST
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.