Past incidents Return to status page

HubSpot may be unavailable for some users

Incident Report for HubSpot

Resolved

HubSpot is now working for all users. We identified and addressed the root cause of the issue that prevented HubSpot from loading, and the issue is fully resolved. No data was lost.
Posted 2 months ago. Jan 07, 2025 - 16:25 EST

Investigating

We're investigating reports that HubSpot may be unavailable for some users. We'll update this page when we have more information.
Posted 2 months ago. Jan 07, 2025 - 16:15 EST