Past incidents Return to status page
Form submission notification emails delayed for all customers
Incident Report for HubSpot
Resolved
All notification emails for form and lead flow submissions during this time frame have now been fully processed and sent. This incident has now been fully resolved.
Posted Aug 17, 2017 - 13:20 EDT
Identified
Notification emails for form and lead flow submissions between 8:20 am on Thursday, Aug 17, 2017 and 09:11 am on Thursday, Aug 17, 2017 EST are currently delayed. All notifications for submissions outside this time range are not impacted. We are currently working to reprocess notification emails for submissions during this time and expect to have all notification emails sent shortly.
Posted Aug 17, 2017 - 09:34 EDT