Past incidents Return to status page
Contacts search is currently delayed for all customers
Incident Report for HubSpot
Resolved
We are fully caught up on processing now and all contacts should display in the UI as expected.
Posted Oct 16, 2017 - 11:45 EDT
Monitoring
We have identified an issue which is causing delays in processing updates to contact records. This resulted in contacts joining a list or view, but not appearing in the list or view UI right away. We've identified the root cause of the issue and implemented a fix. Engineering is now focused on working through the backlog.
Posted Oct 16, 2017 - 11:42 EDT