Past incidents Return to status page
HubSpot is currently unavailable for customers
Incident Report for HubSpot
Resolved
The HubSpot application and HubSpot hosted websites were unavailable between 5:10 and 5:37 PM ET. This was due to a widespread internet issue: https://www.cloudflarestatus.com/incidents/b888fyhbygb8 This issue has now been resolved.

During this time form submissions and some tracking, such as email and website tracking may not have occurred and integrations may have failed to sync to the HubSpot application.
Posted Jul 17, 2020 - 18:23 EDT
Monitoring
The HubSpot application and HubSpot hosted websites were unavailable between 5:10 and 5:37 PM ET. This was due to a widespread internet issue: https://www.cloudflarestatus.com/incidents/b888fyhbygb8 We’re monitoring performance to ensure the HubSpot application recovers properly.
Posted Jul 17, 2020 - 18:03 EDT
Update
We are experiencing an issue with our third-party CDN provider that may affect the availability of the HubSpot application and HubSpot hosted websites. We will update this page as soon as more information is available.
Posted Jul 17, 2020 - 17:38 EDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2020 - 17:27 EDT
Investigating
HubSpot is not loading for all users. We’re investigating the cause of this issue and will update this page when more information is available.
Posted Jul 17, 2020 - 17:27 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.