Past incidents Return to status page
HubSpot is currently experiencing loading delays in Eastern Europe
Incident Report for HubSpot
Resolved
HubSpot software is now working for all users located in Eastern Europe. We've identified and addressed the cause of the issue with our content delivery network provider, Cloudflare, to resolve it. More updates: https://www.cloudflarestatus.com/incidents/fjh89m55qxt7. The incident has now been fully resolved. No data was lost.
Posted Apr 12, 2024 - 10:03 EDT
Investigating
We are investigating a performance issue impacting HubSpot customers located in Eastern Europe. We are working with our content delivery network provider, Cloudflare, to resolve it. More updates: https://www.cloudflarestatus.com/incidents/fjh89m55qxt7
Posted Apr 12, 2024 - 09:44 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.