Past incidents Return to status page
Duplicate meeting invitations are being created for certain Outlook 365 users
Incident Report for HubSpot
Resolved
We have deployed an update which ensures that Outlook 365 users are no longer receiving duplicate meeting invitations.
Posted Nov 07, 2019 - 10:00 EST
Update
We are continuing to monitor the situation related to the Outlook REST API. We have deployed an update to ensure Outlook 365 users are no longer receiving duplicate meeting invitations.
Posted Nov 06, 2019 - 22:44 EST
Monitoring
We have deployed an update which ensures that Outlook 365 users are no longer receiving duplicate meeting invitations. We are continuing to monitor the situation.
Posted Nov 06, 2019 - 19:04 EST
Identified
We’ve identified an issue with the Outlook REST API, causing some users to receive duplicate meeting invitations. We will update this page when more information is available.
Posted Nov 06, 2019 - 14:19 EST
This incident affected: Sales Tools.