Past incidents Return to status page
HubSpot application and publicly hosted content currently unavailable
Incident Report for HubSpot
Resolved
We have resolved an issue that resulted in users being unable to access the HubSpot application and content hosted on the HubSpot platform beginning at 3:31PM ET and ending at 3:37PM ET.
Posted Apr 01, 2020 - 16:17 EDT
Identified
We have identified an issue that resulted in users being unable to access the HubSpot application and content hosted on the HubSpot platform beginning at 3:31PM ET and ending at 3:37PM ET.
Posted Apr 01, 2020 - 16:06 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.