Past incidents Return to status page
HubSpot is currently unavailable for some customers.
Incident Report for HubSpot
Resolved
Between 7:10 am and 9:13 am EST on December 22, our third-party cloud platform, AWS, experienced an outage that caused access issues and delays within HubSpot.

HubSpot functionality has returned for all customers: all tools have recovered and are working as expected.
There is no evidence of any data loss, and any actions that were delayed during the outage period will be successfully retried.
Posted Dec 22, 2021 - 11:54 EST
Update
AWS have indicated that their services have recovered and we see that functionality for the HubSpot product is returning for all customers. We are continuing to monitor the product closely to ensure all processes recover fully and will update this page when when we have more information.
Posted Dec 22, 2021 - 10:47 EST
Monitoring
Between 7:10 am and 9:13 am EST on December 22, our third-party cloud platform, AWS, experienced an outage that caused access and loading issues within HubSpot. AWS have now indicated that their services have recovered and we see that functionality for the HubSpot product is returning for all customers. We are continuing to monitor the product closely to ensure all processes recover fully.
Posted Dec 22, 2021 - 09:40 EST
Update
AWS has indicated that their services are starting to see recovery as of 8.39am EST. We are beginning to see the HubSpot product return to normal and are closely monitoring to ensure all HubSpot functions recover properly. You may read more about this issue here: https://status.aws.amazon.com/
Posted Dec 22, 2021 - 09:11 EST
Update
The outage on our third-party cloud platform provider AWS is ongoing, preventing some customers from accessing HubSpot since 7:10am ET. We’re continuing to work to mitigate this issue to recover functionality as quickly as possible. AWS have acknowledged the issue, and you can read more about it here: https://status.aws.amazon.com/
Posted Dec 22, 2021 - 08:45 EST
Identified
Due to an outage on our third-party cloud platform provider AWS, some customers are currently unable to access HubSpot. We’re actively working to mitigate this issue to recover functionality as quickly as possible. You can read more about the issues here: https://status.aws.amazon.com/
Posted Dec 22, 2021 - 08:11 EST
Investigating
HubSpot is currently unavailable for some users. We’re investigating the cause of this issue, and we'll update this page when we have more information.
Posted Dec 22, 2021 - 07:59 EST