Past incidents Return to status page
Marketing email sends are delayed for some customers
Incident Report for HubSpot
Resolved
Sending of marketing emails is now fully operational. All delayed email sends have been fully processed and caught up.
Posted May 15, 2018 - 14:25 EDT
Investigating
Sending of Marketing Email is delayed up to 35 minutes. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted May 15, 2018 - 14:03 EDT