Past incidents Return to status page
Some HubSpot updates are currently delayed. We're investigating the cause of this issue.
Incident Report for HubSpot
Resolved
Starting 12:04 PM EDT (UTC -04:00) on Oct 30, 2024, customers experienced update delays in several tools. We've addressed the issue that was causing the delays. No data has been lost. We appreciate your patience as we resolved the issue.
Posted Oct 30, 2024 - 15:01 EDT
Monitoring
We've addressed the issue that was causing update delays starting at 12:04 PM EDT (UTC -04:00) on Oct 30, 2024. We're monitoring the tools closely to ensure all processes recover properly.
Posted Oct 30, 2024 - 13:27 EDT
Investigating
Some HubSpot updates are currently delayed. We're investigating the cause of this issue.
Posted Oct 30, 2024 - 12:45 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.