Past incidents Return to status page

HubSpot is currently unavailable for some customers.

Incident Report for HubSpot

Resolved

HubSpot is now working for all users. We identified and addressed the root cause of the issue that prevented HubSpot from loading, and the issue is fully resolved. No data was lost.
Posted Jul 19, 2023 - 10:22 EDT

Monitoring

We've addressed the issue that prevented HubSpot from loading beginning at 10:05 AM EDT (UTC -04:00) on Jul 19, 2023. We're monitoring performance closely to ensure the software recovers properly.
Posted Jul 19, 2023 - 10:17 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.