Past incidents Return to status page
HubSpot is currently unavailable for some customers
Incident Report for HubSpot
Resolved
The issue that prevented HubSpot from loading is fully resolved.

Cloudflare has fully resolved the issue impacting widespread internet unavailability and delays for some users in a limited number of regions, including the United Kingdom, between 6:51 AM ET and 12:19 PM ET. Loading issues for HubSpot users affected by this issue have been resolved, and all HubSpot systems are operational.

Learn More on Cloudflare Status Page https://www.cloudflarestatus.com/incidents/2rkyw681jwfz
Posted Jul 12, 2021 - 12:27 EDT
Update
We are continuing to monitor the fix that Cloudflare implemented to ensure all HubSpot processes recover properly in affected regions.
Learn More on Cloudflare Status Page
https://www.cloudflarestatus.com/
Posted Jul 12, 2021 - 11:49 EDT
Monitoring
Cloudflare has reported a fix was implemented to an issue causing widespread internet unavailability and delays for some users in a limited number of regions, including the United Kingdom. We’re monitoring closely to ensure all processes recover properly in affected regions.

Learn More on Cloudflare Status Page (https://www.cloudflarestatus.com/)
Posted Jul 12, 2021 - 10:49 EDT
Identified
We’ve identified the cause of widespread internet unavailability and delays for some users in some regions as network performance issues with a 3rd party ISP. If you are experiencing intermittent access issues to HubSpot or other web services, you can attempt to refresh and reload. We’ll update this page when we have more information.
Posted Jul 12, 2021 - 09:24 EDT
Investigating
HubSpot is currently unavailable for some users. We’re investigating the cause of this issue, and we'll update this page when we have more information.
Posted Jul 12, 2021 - 08:11 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, and Integrations.