Past incidents Return to status page
Errors on submission of HubSpot Forms for all customers
Incident Report for HubSpot
Resolved
All submissions on HubSpot forms between 1:25 pm and 1:48 pm ET are now fully processed. We’ve identified and addressed the cause of the issue and the incident has now been fully resolved.

No submissions were lost, however customers may see duplicated submissions if visitors to their forms clicked submit multiple times.
Posted Jul 01, 2020 - 17:01 EDT
Monitoring
For 23 minutes, between 1:25 pm and 1:48 pm ET on Wednesday, July 1, submissions on HubSpot Forms appeared to fail when a visitor clicked submit. However, these submissions were successfully sent to HubSpot.

We are currently processing these delayed submissions and expect all form submissions during this timeframe to be processed shortly. We will update this page when more information is available.
Posted Jul 01, 2020 - 16:37 EDT
This incident affected: Marketing Tools.