Past incidents Return to status page
HubSpot is currently unavailable for all customers.
Incident Report for HubSpot
Resolved
HubSpot is now working for all users. We identified and addressed the root cause of the issue that prevented HubSpot from loading, and the issue is fully resolved.
Posted Oct 30, 2023 - 17:01 EDT
Monitoring
We've addressed the issue that's been preventing HubSpot software from loading since 3:55 PM EDT (UTC -04:00) on Oct 30, 2023. HubSpot and HubSpot CMS pages are available for all customers.
Posted Oct 30, 2023 - 16:38 EDT
Identified
We've addressed the issue that's been preventing HubSpot software from loading since 3:55 PM EDT (UTC -04:00) on Oct 30, 2023. HubSpot and HubSpot CMS pages are available for all customers.
Posted Oct 30, 2023 - 16:38 EDT
Update
A Cloudflare outage has caused HubSpot to be unavailable for all users and HubSpot CMS websites to be degraded since 3:56 PM EDT (UTC -04:00) on Oct 30, 2023. We're working with Cloudflare to monitor and address the cause of this issue. You can find Cloudflare's status page here https://www.cloudflarestatus.com/
Posted Oct 30, 2023 - 16:22 EDT
Investigating
HubSpot is currently unavailable for all users. We're investigating the cause of this issue, and we'll update this page when we have more information.
Posted Oct 30, 2023 - 16:08 EDT
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.