HubSpot is currently unavailable for customers in Switzerland
Incident Report for HubSpot
Resolved
The HubSpot app is now loading properly for all users. We’ve identified and addressed the cause of the issue as a partial outage with our third party CDN provider and the incident has now been fully resolved.
Posted 2 months ago. Jun 19, 2019 - 05:37 EDT
Investigating
We’re currently experiencing an issue that’s preventing the HubSpot app from loading for users accessing from Switzerland. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted 2 months ago. Jun 19, 2019 - 05:24 EDT
This incident affected: HubSpot Marketing Application, HubSpot CRM, and HubSpot Sales.