Past incidents Return to status page
Email sends, stats, and list segmentation is currently delayed for some customers
Incident Report for HubSpot
Resolved
This incident has been resolved.
Posted Feb 15, 2017 - 16:16 EST
Investigating
Email processing in HubSpot is now back to normal. We’ve identified and addressed the cause of the issue as a problem with our email tracking database and the incident has now been fully resolved.
Posted Feb 15, 2017 - 16:15 EST
Identified
We have identified the issue causing email delays and expect to be recovered shortly.
Posted Feb 15, 2017 - 16:06 EST
Investigating
HubSpot's email tools are experiencing delays sending and processing data for sent emails. Emails currently being sent, may take longer than normal to complete. Emails recently sent may not show up-to-date stats in the post-send screen. List segmentation based on email data may also be delayed. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted Feb 15, 2017 - 16:03 EST