Past incidents Return to status page

Our Office 365 Add-in for the Outlook for Windows app is unavailable for some customers

Incident Report for HubSpot

Resolved

Office 365 Add-in for Outlook for Windows is now fully accessible. We've identified and addressed the root cause of the issue. The incident has been fully resolved and Office 365 Add-in for Outlook for Windows should be working properly. No data was lost.
Posted 11 months ago. May 22, 2024 - 21:33 EDT

Investigating

Our Office 365 Add-in for the Outlook for Windows app isn't available right now. We're investigating what's causing this issue and will update this page when we have more information.
Posted 11 months ago. May 22, 2024 - 20:50 EDT
This incident affected: Sales Tools.